Networking

User of mysql/mariadb for wordpress

1 min readNo comments yet

Today, I followed a guild to deploy a database using mysql and mariadb for wordpress instance. It failed in a strange way: I can use the user I created for the database to login from bash using mysql command, but wordpress reports access denied.

After a long time digging, the problem is solved:

Creating an account in database for wordpress, "mysql_native_password" is required to be specified, like CREATE USER wp@localhost IDENTIFIED WITH mysql_native_password BY 'password'.

Comments

Leave a comment

Comments are reviewed before they appear.